I
Joined
Likes
0

Profile posts Latest activity Postings About

  • what version of minecraft do i need i have the most recent version but it says incompatable
    moonlightstouch
    moonlightstouch
    Hey there! If you're trying to join the server on 1.17, you won't be able to seeing as our server doesn't currently support 1.17 versions yet. Below is some information that will hopefully be of use to you:

    The IP to the server is play.jailbreakmc.com and you can only join if you have Java edition of Minecraft. The server supports versions 1.8-1.16, but the recommended version to play on is 1.12.2. Hope this helps!
  • Loading…
  • Loading…
  • Loading…